Oracle PeopleSoft

Can no longer run Application Engine programs from Application Designer

I wasted a good couple of hours trying to figure out why my application engine programs would no longer run in Application Designer (two-tier). I have concluded that it is due to a PeopleTools bug in Application Designer. Something was causing the App Engine program to run in an infinite loop. I had to manually close the psae.exe process, and observed that the log file couldn’t even execute the first step of MAIN:

PeopleTools 8.51.03 - Application Engine
Copyright (c) 1988-2011 Oracle and/or its affiliates.
All Rights Reserved

2011-04-05-14.48.24.218016  SearchArchive [1155] Exception logged: RC=3.
2011-04-05-14.48.24.218016  AeCursCheckOutCallState [1119] Exception logged: RC=3.
2011-04-05-14.48.24.218016  GetNextStateRecord [68] Exception logged: RC=3.
2011-04-05-14.48.24.218016  GetNextStateRecord [68] Exception logged: RC=3.
2011-04-05-14.48.24.218032  GetNextStateRecord [68] Exception logged: RC=3.
14.48.25 Tracing Application Engine program JAY_AE Jays Test AE (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\PS\PS\AE_0405144824_2188.AET)
Application Engine Debugger - enter command or type ? for help.

JAY_AE.MAIN.Step01>
Invalid command - please try again or type ? for help

JAY_AE.MAIN.Step01>
Invalid command - please try again or type ? for help

JAY_AE.MAIN.Step01>
Invalid command - please try again or type ? for help

JAY_AE.MAIN.Step01>
Invalid command - please try again or type ? for help

This was really frustrating as it was working all along before. The only way I could get it working again was to deselect the “Debug” checkbox in Configuration Manager. You can do this by performing the following steps:
1. Open Configuration Manager
2. Navigate to the “Profile” tab
3. Click the “Edit” button for the Profile
4. Click on the “Process Scheduler” tab
5. Deselect the “Debug” checkbox on the Application Engine frame

Deselect the "Debug" checkbox on the "Process Scheduler" tab

This is my current workaround, but it means that I’m unable to debug non-PeopleCode Application Engine steps (unless I run psae.exe manually…but then I can’t debug PeopleCode steps!). If anyone knows how to fix this problem, then I’d be grateful if you could let me know :S.

5 thoughts on “Can no longer run Application Engine programs from Application Designer”

    1. I haven’t been able to fix this. Fortunately, I run my environments on a virtual machine with snapshots, so I was able to revert to a previous virtual machine snapshot of my environment.

Leave a Reply to Angel Cancel reply

Your email address will not be published. Required fields are marked *

ERROR: si-captcha.php plugin: GD image support not detected in PHP!

Contact your web host and ask them to enable GD image support for PHP.

ERROR: si-captcha.php plugin: imagepng function not detected in PHP!

Contact your web host and ask them to enable imagepng for PHP.